Implementing Threads for Measurements

by Aquiles Carattino May 29, 2018 measurement multithreading threading threads


This is a companion discussion topic for the original entry at https://pythonforthelab.com/blog/implementing-threads-for-measurements/

What python version and ipython kernel did you use to get this working in jupyter lab? I’m currently using python 3.8.3 and ipython kernel 7.15.0 and find a thread with a loop in it will sometimes run for just one iteration and sometimes for more but almost inevitably stops eventually. At present I’m just trying to duplicate Matthew Rocklin’s results from https://www.youtube.com/watch?v=yI_yZoUaz60&t=740s. I have tried the Tornado solution he lists, asyncio, and threading, all with mixed results at best. Please note I’m not a computer scientist, so my grasp of these concepts is tenuous at best. Any helpful suggestions welcome! :slight_smile:

I have used Python 3.4, 3.5, 3.6, 3.7, 3.8 and it worked in all of them. If you are trying to duplicate someone else’s work, you are going to get faster answers by asking them. If you have any questions regarding the article, then you are welcome to ask and I’ll help you.

I actually did ask him as well, thanks! In a way it’s nice to know there are so many different modules and routes to accomplish the same task, but it’s a bit frustrating when every line of code takes a few hours to figure out. :slight_smile: